STIGQter STIGQter: STIG Summary: SLES 12 Security Technical Implementation Guide Version: 1 Release: 4 Benchmark Date: 24 Jan 2020: The SUSE operating system must have the packages required for multifactor authentication to be installed.

DISA Rule

SV-92203r3_rule

Vulnerability Number

V-77507

Group Title

SRG-OS-000375-GPOS-00160

Rule Version

SLES-12-030500

Severity

CAT II

CCI(s)

Weight

10

Fix Recommendation

Configure the SUSE operating system to implement multifactor authentication by installing the required packages.

Install the packages required to support multifactor authentication with the following commands:

#zypper install pam_pkcs11

#zypper install mozilla-nss

#zypper install mozilla-nss-tools

#zypper install pcsc-ccid

#zypper install pcsc-lite

#zypper install pcsc-tools

#zypper install opensc

#zypper install coolkey

Additional information on the configuration of multifactor authentication on the SUSE operating system can be found at https://www.suse.com/communities/blog/configuring-smart-card-authentication-suse-linux-enterprise/

Check Contents

Verify the SUSE operating system has the packages required for multifactor authentication installed.

Check for the presence of the packages required to support multifactor authentication with the following commands:

# zypper se pam_pkcs11

i | pam_pkcs11 | PKCS #11 PAM Module | package

# zypper se mozilla-nss

i | mozilla-nss | Network Security Services | package
i | mozilla-nss-tools | Tools for developing, debugging, and managing applications t-> | package

# zypper se pcsc

i | pcsc-ccid | PCSC Driver for CCID Based Smart Card Readers and GemPC Twin -> | package
i | pcsc-lite | PCSC Smart Cards Library | package
i | pcsc-tools | PCSC Tools | package

# zypper se opensc

i | opensc | Smart Card Utilities | package

# zypper info coolkey | grep -i installed

Installed: Yes

If any of the packages required for multifactor authentication are not installed, this is a finding.

Vulnerability Number

V-77507

Documentable

False

Rule Version

SLES-12-030500

Severity Override Guidance

Verify the SUSE operating system has the packages required for multifactor authentication installed.

Check for the presence of the packages required to support multifactor authentication with the following commands:

# zypper se pam_pkcs11

i | pam_pkcs11 | PKCS #11 PAM Module | package

# zypper se mozilla-nss

i | mozilla-nss | Network Security Services | package
i | mozilla-nss-tools | Tools for developing, debugging, and managing applications t-> | package

# zypper se pcsc

i | pcsc-ccid | PCSC Driver for CCID Based Smart Card Readers and GemPC Twin -> | package
i | pcsc-lite | PCSC Smart Cards Library | package
i | pcsc-tools | PCSC Tools | package

# zypper se opensc

i | opensc | Smart Card Utilities | package

# zypper info coolkey | grep -i installed

Installed: Yes

If any of the packages required for multifactor authentication are not installed, this is a finding.

Check Content Reference

M

Target Key

2903

Comments