STIGQter STIGQter: STIG Summary: EDB Postgres Advanced Server Security Technical Implementation Guide Version: 1 Release: 6 Benchmark Date: 25 Oct 2019: The EDB Postgres Advanced Server must check the validity of all data inputs except those specifically identified by the organization.

DISA Rule

SV-83573r2_rule

Vulnerability Number

V-68969

Group Title

SRG-APP-000251-DB-000160

Rule Version

PPS9-00-006200

Severity

CAT II

CCI(s)

Weight

10

Fix Recommendation

Install and configure SQL/Protect as documented here:

http://www.enterprisedb.com/docs/en/9.5/eeguide/Postgres_Plus_Enterprise_Edition_Guide.1.072.html#

Alternatively, implement, document, and maintain another method of checking for the validity of inputs.

Check Contents

Execute the following SQL as enterprisedb:

SELECT * FROM sqlprotect.list_protected_users;

If the database and user that handles user input is not listed or if sqlprotect.list_protected_users does not exist (meaning SQL/Protect is not installed), and an alternative means of reviewing for vulnerable code is not in use, this is a finding.

Vulnerability Number

V-68969

Documentable

False

Rule Version

PPS9-00-006200

Severity Override Guidance

Execute the following SQL as enterprisedb:

SELECT * FROM sqlprotect.list_protected_users;

If the database and user that handles user input is not listed or if sqlprotect.list_protected_users does not exist (meaning SQL/Protect is not installed), and an alternative means of reviewing for vulnerable code is not in use, this is a finding.

Check Content Reference

M

Target Key

2933

Comments