STIGQter STIGQter: STIG Summary: Cisco IOS Router RTR Security Technical Implementation Guide Version: 1 Release: 2 Benchmark Date: 24 Jan 2020: The Cisco multicast Designated Router (DR) must be configured to filter the Internet Group Management Protocol (IGMP) and Multicast Listener Discovery (MLD) Report messages to allow hosts to join a multicast group only from sources that have been approved by the organization.

DISA Rule

SV-105797r1_rule

Vulnerability Number

V-96659

Group Title

SRG-NET-000364-RTR-000115

Rule Version

CISC-RT-000870

Severity

CAT II

CCI(s)

Weight

10

Fix Recommendation

Configure the DR to filter the IGMP and MLD report messages to allow hosts to join only those multicast groups from sources that have been approved as shown in the example.

R3(config)#ip access-list extended IGMP_JOIN_FILTER
R3(config-ext-nacl)#deny ip any 232.8.0.0 0.0.255.255
R3(config-ext-nacl)#permit ip x.0.0.0 0.255.255.255 any
R3(config-ext-nacl)#deny ip any any
R3(config-ext-nacl)#exit

Step 2: Apply the filter to all host facing interfaces.

R3(config)#int g0/0
R3(config-if)#ip igmp access-group IGMP_JOIN_FILTER

Check Contents

Review the configuration of the DR to verify that it is filtering IGMP or MLD report messages, allowing hosts to only join multicast groups from sources that have been approved.

Step 1: Verify that all host-facing interfaces are configured to filter IGMP Membership Report messages (IGMP joins) as shown in the example below.

interface GigabitEthernet0/0
ip address 10.3.3.3 255.255.255.0
ip pim sparse-mode
ip igmp access-group IGMP_JOIN_FILTER
ip igmp version 3

Step 2: Verify that the Access Control List (ACL) denies unauthorized sources or allows only authorized sources. The example below denies all groups from 232.8.0.0/16 range and permits sources only from the x.0.0.0/8 network.

ip access-list extended IGMP_JOIN_FILTER
deny ip any 232.8.0.0 0.0.255.255
permit ip x.0.0.0 0.255.255.255 any
deny ip any any

Note: This requirement is only applicable to Source Specific Multicast (SSM) implementation.

If the DR is not filtering IGMP or MLD report messages, this is a finding.

Vulnerability Number

V-96659

Documentable

False

Rule Version

CISC-RT-000870

Severity Override Guidance

Review the configuration of the DR to verify that it is filtering IGMP or MLD report messages, allowing hosts to only join multicast groups from sources that have been approved.

Step 1: Verify that all host-facing interfaces are configured to filter IGMP Membership Report messages (IGMP joins) as shown in the example below.

interface GigabitEthernet0/0
ip address 10.3.3.3 255.255.255.0
ip pim sparse-mode
ip igmp access-group IGMP_JOIN_FILTER
ip igmp version 3

Step 2: Verify that the Access Control List (ACL) denies unauthorized sources or allows only authorized sources. The example below denies all groups from 232.8.0.0/16 range and permits sources only from the x.0.0.0/8 network.

ip access-list extended IGMP_JOIN_FILTER
deny ip any 232.8.0.0 0.0.255.255
permit ip x.0.0.0 0.255.255.255 any
deny ip any any

Note: This requirement is only applicable to Source Specific Multicast (SSM) implementation.

If the DR is not filtering IGMP or MLD report messages, this is a finding.

Check Content Reference

M

Target Key

3477

Comments